пятница, 12 ноября 2010 г.

Лабораторки CCNA #001

Пример настройки статической маршрутизации на роутерах cisco.

Топология.


Настройка.
R1:
R1>enable
R1#configure terminal

R1(config)# interface FastEthernet 0/0
R1(config-if)# ip address 172.16.3.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# int se 2/0
R1(config-if)# ip address 172.16.2.1 255.255.255.0
R1(config-if)# clock rate 64000
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# ip route 0.0.0.0 0.0.0.0 172.16.2.2

R2:
R2>enable
R2#configure terminal

R2(config)# interface FastEthernet 0/0
R2(config-if)# ip address 172.16.1.1 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# exit

R2(config)# int se 2/0
R2(config-if)# ip address 172.16.2.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# exit

R2(config)# int se 3/0
R2(config-if)# ip address 192.168.1.2 255.255.255.0
R2(config-if)# clock rate 64000
R2(config-if)# no shutdown
R2(config-if)# exit

R2(config)# ip route 172.16.3.0 255.255.255.0 172.16.2.1
R2(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.1

R3:

R3>enable
R3#configure terminal

R3(config)# interface FastEthernet 0/0
R3(config-if)# ip address 192.168.2.1 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# exit

R3(config)# int se 2/0
R3(config-if)# ip address 212.190.60.2 255.255.255.252
R3(config-if)# no shutdown
R3(config-if)# exit

R3(config)# int se 3/0
R3(config-if)# ip address 192.168.1.1 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# exit

R3(config)# ip route 172.16.0.0 255.255.252.0 192.168.1.2
R3(config)# ip route 0.0.0.0 0.0.0.0 212.190.60.1

PS:
1. на R3 используется суммарный маршрут

2. для ускорения форвардинга пакетов, вместо ip адреса nexthop можно было указать выходной интерфейс.

R1(config)# ip route 0.0.0.0 0.0.0.0 serial 2/0

R2(config)# ip route 172.16.3.0 255.255.255.0 serial 2/0
R2(config)# ip route 0.0.0.0 0.0.0.0 serial 3/0

R3(config)# ip route 172.16.0.0 255.255.252.0 serial 3/0
R3(config)# ip route 0.0.0.0 0.0.0.0 serial 2/0

2 комментария:

  1. Подозреваю, что ошибка в строке:
    R2(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.2
    должно быть:
    R2(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.1

    ОтветитьУдалить

Примечание. Отправлять комментарии могут только участники этого блога.