пятница, 26 ноября 2010 г.

Лабораторки CCNA #003/2

Пример настройки протокола динамической маршрутизации EIGRP на роутерах cisco с ipv6 адресацией.
Топология.

Настройка:
R1:
Router> en
Router# configure terminal
Router(config)# hostname R1
R1(config)# ipv6 unicast-routing

R1(config)# interface fastethernet 0/0
R1(config-if)# ipv6 enable
R1(config-if)# ipv6 address 2001:128:0:10::1/64
R1(config-if)# ipv6 eigrp 1
R1(config-if)# no shutdown

R1(config)# interface fastethernet 0/1
R1(config-if)# ipv6 enable
R1(config-if)# ipv6 address 2001:128:0:30::1/64
R1(config-if)# ipv6 eigrp 1
R1(config-if)# no shutdown

R1(config)# interface serial 0/3/0
R1(config-if)# ipv6 enable
R1(config-if)# ipv6 address 2001:128:0:40::1/64
R1(config-if)# bandwidth 250
R1(config-if)# ipv6 eigrp 1
R1(config-if)# no shutdown

R1(config)# interface serial 0/3/1
R1(config-if)# ipv6 enable
R1(config-if)# ipv6 address 2001:128:0:50::1/64
R1(config-if)# bandwidth 250
R1(config-if)# ipv6 eigrp 1
R1(config-if)# no shutdown

R1(config)# ipv6 router eigrp 1
R1(config-router)# router-id 192.168.1.1
R1(config-router)# no shutdown

R1# copy running-config startup-config

R2:
Router> en
Router# configure terminal
Router(config)# hostname R2
R2(config)# ipv6 unicast-routing

R2(config)# interface fastethernet 0/0
R2(config-if)# ipv6 enable
R2(config-if)# ipv6 address 2001:129:0:1::2/64
R2(config-if)# no shutdown

R2(config)# interface serial 0/2/0
R2(config-if)# ipv6 enable
R2(config-if)# ipv6 address 2001:128:0:40::2/64
R2(config-if)# ipv6 eigrp 1
R2(config-if)# bandwidth 250
R2(config-if)# clock rate 250000
R2(config-if)# no shutdown

R2(config)# interface serial 0/2/1
R2(config-if)# ipv6 enable
R2(config-if)# ipv6 address 2001:128:0:60::1/64
R2(config-if)# ipv6 eigrp 1
R2(config-if)# bandwidth 250
R2(config-if)# clock rate 250000
R2(config-if)# no shutdown

R2(config)# ipv6 router eigrp 1
R2(config-router)# router-id 192.168.1.2
R2(config-router)# redistribute static
R2(config-router)# no shutdown

R2(config)# ipv6 route ::/0 fastethernet 0/0

R2# copy running-config startup-config

R3:
Router> en
Router# configure terminal
Router(config)# hostname R3
R3(config)# ipv6 unicast-routing

R3(config)# interface fastethernet 0/0
R3(config-if)# ipv6 enable
R3(config-if)# ipv6 address 2001:128:0:20::1/64
R3(config-if)# ipv6 eigrp 1
R3(config-if)# no shutdown

R3(config)# interface fastethernet 0/1
R3(config-if)# ipv6 enable
R3(config-if)# ipv6 address 2001:128:0:30::2/64
R3(config-if)# ipv6 eigrp 1
R3(config-if)# no shutdown

R3(config)# interface serial 0/3/0
R3(config-if)# ipv6 enable
R3(config-if)# ipv6 address 2001:128:0:60::2/64
R3(config-if)# ipv6 eigrp 1
R3(config-if)# bandwidth 250
R3(config-if)# no shutdown

R3(config)# interface serial 0/3/1
R3(config-if)# ipv6 enable
R3(config-if)# ipv6 address 2001:128:0:70::1/64
R3(config-if)# bandwidth 250
R3(config-if)# ipv6 eigrp 1
R3(config-if)# no shutdown

R3(config)# ipv6 router eigrp 1
R3(config-router)# router-id 192.168.1.3
R3(config-router)# no shutdown

R3# copy running-config startup-config

R4:
Router> en
Router# configure terminal
Router(config)# hostname R4
R4(config)# ipv6 unicast-routing

R4(config)# interface fastethernet 0/0
R4(config-if)# ipv6 enable
R4(config-if)# ipv6 address 2001:130:0:1::1/64
R4(config-if)# ipv6 rip cisco
R4(config-if)# no shutdown

R4(config)# interface serial 0/2/0
R4(config-if)# ipv6 enable
R4(config-if)# ip address 2001:128:0:70::1/64
R4(config-if)# bandwidth 250
R4(config-if)# clock rate 250000
R4(config-if)# ipv6 eigrp 1
R4(config-if)# no shutdown

R4(config)# interface serial 0/2/1
R4(config-if)# ipv6 enable
R4(config-if)# ip address 2001:128:0:50::2/64
R4(config-if)# bandwidth 250
R4(config-if)# clock rate 250000
R4(config-if)# ipv6 eigrp 1
R4(config-if)# no shutdown

R4(config)# router eigrp 1
R4(config-router)# router-id 192.168.1.4
R4(config-router)# redistribute rip cisco metric 100000 20 200 50 1500
R4(config-router)# redistribute connected
R4(config-router)# no shutdown

R4(config)# ipv6 router rip cisco
R4(config-router)# redistribute eigrp 1 metric 2
R4(config-router)# redistribute conected

R4# copy running-config startup-config
Табличка маршрутизации 1:
Табличка маршрутизации 2:
Табличка маршрутизации 3:
Табличка маршрутизации 4:
Табличка топологий роутера 1:
На роутерах 1-3 запушен только EIGRP. На роутере 2 настроена редистрибьюция статических маршрутов соседям. На роутере 4 включены два протокола маршрутизации и настроена редистрибьюция маршрутов из EIGRP в RIP и наоборот. На роутере 5 запущен только RIPng.
Таблица топологии наглядно иллюстрирует работу алгоритма DUAL. Буква P указывает, что маршруты стабильны. Указаны feasible distance, сколько successor-ов на маршрутах и сколько feasible successor-ов.

3 комментария:

  1. Пару ошибочек в настройке.
    1)При настройке R4
    !!!!!!!!!!!!!!!!R4(config)# router eigrp 1!!!!!!!!!!!!!!!!!!!
    R4(config-router)# router-id 192.168.1.4
    R4(config-router)# redistribute rip cisco metric 100000 20 200 50 1500
    R4(config-router)# redistribute connected
    R4(config-router)# no shutdown

    Должно быть R4(config)#ipv6 router eigrp 1

    2) R4(config)# interface fastethernet 0/0
    R4(config-if)# ipv6 enable
    R4(config-if)# ipv6 address 2001:130:0:1::1/64
    R4(config-if)# ipv6 rip cisco!!!!!!!!!!!!!!!!
    R4(config-if)# no shutdown

    Должно быть
    R4(config-if)# ipv6 rip cisco enable

    ОтветитьУдалить
  2. и всё равно, настроив как у тебя, топология и таб. маршрутизации такая же не вышла, меньше записей намного( незнаю в чём трабл

    ОтветитьУдалить
  3. если Вам не трудно, скинь семпл PacketTracer'a с этой топологией. немогу настроить.
    1) icq - 6565383
    2) skype - wet_dog1
    3) e-mail - russiancisco@gmail.com

    ОтветитьУдалить

Примечание. Отправлять комментарии могут только участники этого блога.