пятница, 17 декабря 2010 г.

Лабораторка на vlan+vtp

Пример настройки VLAN с использованием Vlan Trunking Protocol на коммутаторах Cisco.

Настройка:
S1:

Switch> en
Switch# configure terminal
Switch(config)# hostname S1
S1(config)# line vty 0 15
S1(config-line)# password cisco
S1(config-line)# login

S1(config)# vtp domain cisco
S1(config)# vtp password cisco

S1(config)# vlan 10
S1(config-vlan)# name student
S1(config)# vlan 20
S1(config-vlan)# name faculty
S1(config)# vlan 30
S1(config-vlan)# name management

S1(config)# interface range fastethernet 0/1-4
S1(config-if)# switchport mode access
S1(config-if)# spanning-tree portfast
S1(config-if)# switchport port-security
S1(config-if)# switchport port-security maximum 1
S1(config-if)# switchport port-security mac-address sticky

S1(config)# interface range fastethernet 0/1-2
S1(config-if)# switchport access vlan 10

S1(config)# interface range fastethernet 0/3-4
S1(config-if)# switchport access vlan 20

S1(config)# interface range fastethernet 0/24
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 30
S1(config-if)# spanning-tree portfast
S1(config-if)# switchport port-security
S1(config-if)# switchport port-security maximum 1
S1(config-if)# switchport port-security mac-address sticky

S1(config)# interface range fastethernet 0/5-23
S1(config-if)# shutdown

S1(config)# interface gigabitEthernet 1/1
S1(config-if)# switchport mode trunk
S1(config-if)# switchport trunk native vlan 30
S1(config-if)# switchport trunk allowed vlan 10,20,30

S1(config)# interface gigabitEthernet 1/2
S1(config-if)# shutdown

S1# copy running-config startup-config
Второй коммутатор настраивается аналогично, кроме Vtp domain и vlan, он их получит динамически после поднятия trunk линка. Пароль и версия vtp  должны быть назначены вручную на обоих коммутаторах.

Vlan 10 - 192.168.1.0/24
Vlan 20 - 192.168.2.0/24
Vlan 30 - 192.168.3.0/24

Понятно что в данной топологии общение между vlan будет невозможно из-за отсутствия устройства 3го уровня. Чтобы позволить компьютерам из разных vlan обмениватся информацией нужно добавить в топологию маршрутизатор или коммутатор 3 уровня.

Проверяем:
Табличка коммутации
Транковые интерфейсы
Статус VTP
VLAN-ы

3 комментария:

  1. * оба свича в режиме vtp server
    * используется версия vtp по умолчанию

    ОтветитьУдалить
  2. А нет лабы про маршуртизацию между VLAN?

    ОтветитьУдалить
  3. вот же http://blog.evgenybelkin.ru/2010/12/inter-vlan-routing.html

    ОтветитьУдалить

Примечание. Отправлять комментарии могут только участники этого блога.