вторник, 25 января 2011 г.

Лабораторка на Dynamic NAT

Пример настройки динамического NAT на маршрутизаторах Cisco.
Настройка:
GW:

GW(config)# interface fastethernet 0/0
GW(config-if)# ip address 209.165.200.2 255.255.255.252
GW(config-if)# ip nat outside
GW(config-if)# no shutdown

GW(config)# interface fastethernet 0/1
GW(config-if)# ip address 192.168.0.1 255.255.255.0
GW(config-if)# ip nat inside
GW(config-if)# no shutdown

Router(config)# access-list 1 permit 192.168.0.0 0.0.0.255

GW(config)# ip nat pool CISCO 209.165.200.9 209.165.200.14 netmask 255.255.255.248
GW(config)# ip nat inside source list 1 pool CISCO
GW(config)# ip route 0.0.0.0 0.0.0.0 209.165.200.1

GW# copy running-config startup-config
Проверяем конфигурацию:

Скачать: pkt-файл

3 комментария:

  1. GW(config)# ip nat inside source list NAT pool NAT

    А для чего эта строка? Есть ведь ip nat inside source list 1 pool CISCO. Зачем тогда ip nat inside source list NAT pool NAT?

    ОтветитьУдалить
  2. Спасибо. Действительно, это ошибка. Поправил текст.

    ОтветитьУдалить
  3. Сделал лабораторную работу и столкнулся с интересной проблемой. Пакеты ICMP от PC1 до узла, которое в облачке (у меня там сервер) успешно проходят, при этом из вывода команды show ip nat translations видно, что трансляция выполняется. Но вот самое интересное... после этого не проходит ping с PC2, из той же подсети, что и PC1, до узла которое в облачке. С чем это может быть связано?

    PS: Топология и конфигурация совпадает. Разве, что у меня вместо облака сервер и нет PC0.

    PSS: Если сначала выполнить ping с PC2 до облачка, то ping не будет проходит на PC1. То есть это наоборот от того, что я описал выше.

    ОтветитьУдалить

Примечание. Отправлять комментарии могут только участники этого блога.