суббота, 9 февраля 2013 г.

EtherChannel между коммутаторами - LACP.

EtherChannel позволяет объединить несколько физических соединений между двумя устройствами в виртуальные. Это дает нам прирост пропускной способности, защищает от возникновения петель 2 уровня и добавляет отказоустойчивости. EtherChannel может быть настроен статически (mode on) или же с использованием протоколов PAgP/LACP. Рассмотрим пример настройки etherchannel между двумя коммутаторами с использованием LACP:
Топология:
Настройка:
3560:
SW1(config)# interface range FastEthernet0/1-3
SW1(config-if-range)# channel-protocol lacp
SW1(config-if-range)# channel-group 1 mode active

SW1(config)# interface Port-channel 1
SW1(config-if)# switchport trunk encapsulation dot1q
SW1(config-if)# switchport mode trunk

SW1(config)# port-channel load-balance src-dst-mac
 
2960:
SW2(config)# interface range FastEthernet0/1-3
SW2(config-if-range)# channel-protocol lacp
SW2(config-if-range)# channel-group 1 mode active

SW2(config)# interface Port-channel 1
SW2(config-if)# switchport mode trunk

SW2(config)# port-channel load-balance src-dst-mac

Проверяем:
show portchannel {summary}
Послесловие:
  • EtherChannel - не удваивает(утраивает) скорость, т.к. фреймы будут распределяться по физическим линиям с учетом выбранного метода (src-ip, dst-ip, src-dst-ip, src-mac, dst-mac, src-dst-mac).
  • Для построения etherchannel все входящие в него порты должны иметь одинаковые настройки, скорость, тип среды.
  • Ограничение на количество портов в один portchannel, не запрещает вам ввести большее количество портов. просто в этом случае такие порты не будут задействованы до отказа активных портов. Дополнительно можно указать какие из портов должны быть активными.
  • EtherChannel можно строить как на L2 портах так и на L3 портах.
  • EtherChannel может быть задействован между коммутаторами и маршрутизаторами, сетевыми хранилищами, серверами и т.д.
Скачать: pkt-файл
Ссылки:

9 комментариев:

  1. Почему обa channel-group находятся в одинаковом режиме Active, Насколько я знаю один из channel-group должен быть в режиме passive??

    ОтветитьУдалить
    Ответы
    1. Etherchannel подымается если с обоих сторон active-active, active-passive или on-on. Если с обеих сторон passive-passive то не будет работать.

      Удалить
    2. по поводу |active-active" не совсем ясно... Ну и что что оба могут быть инициатором чем это хорошо или плохо? :)
      Другое дело, если конфигурации с разных сторона разные, т.е. сторона 1 например предлагает иной вид распределения нагрузки, чем установлено на 2. тогда становится ясно, что если мы хотим менять настройки на 1 стороне (тип распределения нагрузки) то нужно делать active - passive чтоб сторона 2 принимала условия игры
      Но, тогда опять же НЕ ясно нафига нужен active-active? Ну разве что чтоб они хоть до чего-то договорились. Если не о том что настроено на 1 стороне так хоть на второй.

      Удалить
    3. тип балансировки по lacp не согласуется.
      согласуются параметры необходимые для агрегации канала.
      так что active-active нормальная ситуация.

      Удалить
    4. active — Включить LACP,
      passive — Включить LACP только если придет сообщение LACP

      Согласование для установки взаимной агрегации будет только на совпадение параметров каждых отдельных физических портов. Согласование будет происходить после инициации. Если порт в состоянии passive он не будет первым инициировать соединение, соответственно если оба порта напротив друг друга будут находиться в состоянии passive инициация попросту не произойдёт. Во всех остальных случаях только вопрос первого предложения инициации, а кто кому предложил концептуального значения не имеет. Согласование же применяется уже к логическому интерфейсу, тут никто ни с кем не договаривается -- тут уже молча выполняется команда. Вроде так.

      Удалить
  2. Можно ли по подробнее разобрать тему о балансировки трафика по методам:
    (src-ip, dst-ip, src-dst-ip, src-mac, dst-mac, src-dst-mac) ?

    ОтветитьУдалить
    Ответы
    1. вот тут почитай. http://img.nag.ru/projects/setup/227/77b4fd0e8d4491b97e6840f5de1d5ced.pdf или в CCNP.

      Удалить
  3. http://xgu.ru/wiki/%C0%E3%F0%E5%E3%E8%F0%EE%E2%E0%ED%E8%E5_%EA%E0%ED%E0%EB%EE%E2#.D0.A1.D0.B8.D0.BD.D1.82.D0.B0.D0.BA.D1.81.D0.B8.D1.81_.D0.BA.D0.BE.D0.BC.D0.B0.D0.BD.D0.B4.D1.8B_channel-group

    Про режимы

    ОтветитьУдалить

Примечание. Отправлять комментарии могут только участники этого блога.