четверг, 12 апреля 2012 г.

Cisco ISR как PPPoe Client

Предположим, что наш провайдер выдает доступ по pppoe, что довольно часто встречается. Не нервничаем, берем железяку и настраиваем.

# Интерфейс идущий в локалку
interface FastEthernet0/0
description $LAN$
ip address 172.16.1.1 255.255.255.128
ip nat inside
# Интерфейс идущий к провайдеру
interface FastEthernet0/1
description $WAN$
no ip address
pppoe enable group global
pppoe-client dial-pool-number 1
# Виртуальный интерфейс ppp
interface Dialer0
description $OUTSIDE$
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp authentication chap callin
ppp chap hostname <login>
ppp chap password <password>
ppp ipcp dns request
# Указываем лист доступа для NAT
access-list 1 permit 172.16.1.0 0.0.0.127
# Указываем маршрут по умолчанию
ip route 0.0.0.0 0.0.0.0 Dialer0
# Включаем NAT с перегрузкой
ip nat inside source list 1 interface Dialer0 overload
# Проверить работоспособность сессии можно командой
Router# sh pppoe session interface fa 0/1

PS Конфиг проверен на Cisco ISR 2801 (c2801-advsecurityk9-mz.124-15.t9.bin). У счастливых обладателей роутеров cisco с ios 15.0 наблюдаются проблемы с pppoe client. Рекомендуется либо откатиться на 12.4, либо обновиться на 15.1. Я выбрал первое.

Комментариев нет:

Отправить комментарий

Примечание. Отправлять комментарии могут только участники этого блога.