среда, 6 июля 2011 г.

OSPF Stub, Totally Stub, NSSA, Totally NSSA

OSFP предполагает построение сложных иерархичных сетей. Помимо разделения на backbone область и обычные области (которые должны быть подключены к backbone), существуют так же различные типы обычных областей.
Stub область - в нее разрешено передавать только маршрут по умолчанию и IA маршруты.
Totally Stub область - в нее разрешено передавать только маршрут по умолчанию
NSSA область - разрешено передавать IA маршруты, внешние маршруты + маршрут по умолчанию
Totally NSSA область - разрешено передавать внешние маршруты + маршрут по умолчанию

Топология:

Настройка:
R1:
router ospf 1
log-adjacency-changes
area 1 stub no-summary
area 2 stub
network 192.168.1.0 0.0.0.3 area 1
network 172.16.1.0 0.0.0.3 area 0
network 192.168.1.4 0.0.0.3 area 2
R2:
router ospf 1
log-adjacency-changes
area 3 nssa
area 4 nssa no-summary
redistribute rip metric 3 subnets
network 172.16.1.0 0.0.0.3 area 0
network 192.168.1.12 0.0.0.3 area 3
network 192.168.1.16 0.0.0.3 area 4

router rip
version 2
redistribute ospf 1 metric 1
network 192.168.1.0
no auto-summary
R3:
router ospf 1
log-adjacency-changes
area 1 stub
passive-interface FastEthernet0/0
network 192.168.1.0 0.0.0.3 area 1
network 192.168.2.0 0.0.0.255 area 1
R4:
router ospf 1
log-adjacency-changes
area 2 stub
passive-interface FastEthernet0/1
network 192.168.1.4 0.0.0.3 area 2
network 192.168.3.0 0.0.0.255 area 2
R5:
router rip
version 2
passive-interface FastEthernet0/0
network 192.168.1.0
network 192.168.4.0
no auto-summary
R6:
router ospf 1
log-adjacency-changes
area 3 nssa
passive-interface FastEthernet0/1
network 192.168.1.12 0.0.0.3 area 3
network 192.168.5.0 0.0.0.3 area 3
R7:
router ospf 1
log-adjacency-changes
area 4 nssa
passive-interface FastEthernet0/1
network 192.168.1.16 0.0.0.3 area 4
network 192.168.6.0 0.0.0.255 area 4
Проверяем:
Таблица маршрутизации R1
Таблица маршрутизации R2
Таблица маршрутизации R3
Таблица маршрутизации R4
Таблица маршрутизации R6

Таблица маршрутизации R7

* маршруты с пометкой N(LSA7), аналогичны внешним маршрутам E(LSA5)
* на роутерах R7 и R3 нет необходимости указывать параметр no-summary, достаточно это сделать на пограничных роутерах R1 и R2

Скачать: pkt-файл

3 комментария:

  1. Этот комментарий был удален автором.

    ОтветитьУдалить
  2. Откуда на R7 взялся маршрут
    O N2 192.168.1.12 ?

    В pkt-файле его нет, да и не должно его там быть, кмк.

    ОтветитьУдалить
    Ответы
    1. области с nssa типом могут иметь ASBR роутер и могут перераспределять внешние маршруты, обычные же stub-области этого не могут.
      NSSA и Totally NSSA позволяют иметь ASBR в качестве члена области. Так как LSA 5 типа не разрешены, то ASBR использует LSA типа 7 для перераспределения внешних маршрутов в область.

      Удалить

Примечание. Отправлять комментарии могут только участники этого блога.