пятница, 22 июля 2011 г.

EIGRP Authentication + Manual Summarization

Пример настройки EIGRP с аутентификацией и ручной суммаризацией маршрутов между роутерами.
При настройке аутентификации соседей используем параметры времени в течение которого ключи актуальны для отправки и приема, а так же использование md5 хешей вместо передачи ключа открытым текстом.
При объявлении сумарных маршрутов вручную (так же как и в автоматическом случае) в таблице маршрутизации появляется маршрут на интерфейс null, испольуемый для предотвращения возможных петель трафика.
Топология:

Настройка:
R1:
!
key chain mykeys
key 1
key-string cisco1
accept-lifetime 12:00:00 Jul 22 2011 12:00:00 Jul 23 2011
send-lifetime 12:00:00 Jul 22 2011 12:00:00 Jul 23 2011
!
interface FastEthernet0/0
ip address 209.165.200.1 255.255.255.252
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 mykeys
ip summary-address eigrp 1 192.168.0.0 255.255.252.0 5
!
router eigrp 1
passive-interface default
no passive-interface FastEthernet0/0
network 192.168.0.0 0.0.3.255
network 209.165.200.0 0.0.0.3
no auto-summary
!
R2:
!
key chain mykeys
key 1
key-string cisco1
accept-lifetime 12:00:00 Jul 22 2011 12:00:00 Jul 23 2011
send-lifetime 12:00:00 Jul 22 2011 12:00:00 Jul 23 2011
!
interface FastEthernet0/0
ip address 209.165.200.2 255.255.255.252
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 mykeys
ip summary-address eigrp 1 192.168.4.0 255.255.252.0 5
!
interface FastEthernet1/0
ip address 209.165.200.5 255.255.255.252
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 mykeys
ip summary-address eigrp 1 192.168.0.0 255.255.248.0 5
!
router eigrp 1
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface FastEthernet1/0
network 192.168.4.0 0.0.3.255
network 209.165.200.0 0.0.0.7
no auto-summary
!
R3:
!
key chain mykeys
key 1
key-string cisco1
accept-lifetime 12:00:00 Jul 22 2011 12:00:00 Jul 23 2011
send-lifetime 12:00:00 Jul 22 2011 12:00:00 Jul 23 2011
!
interface FastEthernet1/0
ip address 209.165.200.6 255.255.255.252
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 mykeys
ip summary-address eigrp 1 192.168.8.0 255.255.252.0 5
!
router eigrp 1
passive-interface default
no passive-interface FastEthernet1/0
network 192.168.8.0 0.0.3.255
network 209.165.200.4 0.0.0.3
no auto-summary
!
Проверяем:
Таблица маршрутизации R1:
Таблица маршрутизации R2:
Таблица маршрутизации R3:

PS Соседи используют общий ключ для аутентификации. Роутеры должны синхронизировать свои часы, иначе время приема может не совпасть.
PPS При наличии нескольких ключей, для отправки используется ключ с меньшим номером, для приема проверяются все ключи.

2 комментария:

Примечание. Отправлять комментарии могут только участники этого блога.