пятница, 26 ноября 2010 г.

Лабораторки CCNA #003

Пример настройки протокола динамической маршрутизации EIGRP на роутерах cisco.
Топология.



Настройка:
R1:
Router> en
Router# configure terminal
Router(config)# hostname R1

R1(config)# interface fastethernet 0/0
R1(config-if)# ip address 192.168.2.5 255.255.255.252
R1(config-if)# no shutdown

R1(config)# interface fastethernet 0/1
R1(config-if)# ip address 172.16.1.1 255.255.255.0
R1(config-if)# no shutdown

R1(config)# interface serial 0/3/0
R1(config-if)# ip address 192.168.2.1 255.255.255.252
R1(config-if)# clock rate 128000
R1(config-if)# bandwidth 128
R1(config-if)# no shutdown

R1(config)# interface serial 0/3/1
R1(config-if)# ip address 192.168.2.9 255.255.255.252
R1(config-if)# clock rate 250000
R1(config-if)# bandwidth 250
R1(config-if)# no shutdown

R1(config)# router eigrp 1
R1(config-router)# no auto-summary
R1(config-router)# network 192.168.2.0 0.0.0.3
R1(config-router)# network 192.168.2.4 0.0.0.3
R1(config-router)# network 192.168.2.8 0.0.0.3
R1(config-router)# network 172.16.1.0 0.0.0.255
R1(config-router)# passive-interface fastethernet 0/1

R1# copy running-config startup-config

R2:
Router> en
Router# configure terminal
Router(config)# hostname R2

R2(config)# interface fastethernet 0/0
R2(config-if)# ip address 192.168.2.6 255.255.255.252
R2(config-if)# no shutdown

R2(config)# interface fastethernet 0/1
R2(config-if)# ip address 192.168.2.13 255.255.255.255
R2(config-if)# no shutdown

R2(config)# interface serial 0/3/0
R2(config-if)# ip address 209.165.200.2 255.255.255.252
R2(config-if)# no shutdown

R2(config)# router eigrp 1
R2(config-router)# no auto-summary
R2(config-router)# network 192.168.2.4 0.0.0.3
R2(config-router)# network 192.168.2.12 0.0.0.3
R2(config-router)# redistribute static
R2(config-router)# passive-interface serial 0/3/0

R2(config)# ip route 0.0.0.0 0.0.0.0 se 0/3/0

R2# copy running-config startup-config

R3:
Router> en
Router# configure terminal
Router(config)# hostname R3

R3(config)# interface fastethernet 0/0
R3(config-if)# ip address 172.16.2.1 255.255.255.0
R3(config-if)# no shutdown

R3(config)# interface fastethernet 0/1
R3(config-if)# ip address 192.168.2.14 255.255.255.252
R3(config-if)# no shutdown

R3(config)# interface serial 0/3/0
R3(config-if)# ip address 192.168.2.2 255.255.255.252
R3(config-if)# clock rate 128000
R3(config-if)# bandwidth 128
R3(config-if)# no shutdown

R3(config)# interface serial 0/3/1
R3(config-if)# ip address 192.168.2.18 255.255.255.252
R3(config-if)# clock rate 250000
R3(config-if)# bandwidth 250
R3(config-if)# no shutdown

R3(config)# router eigrp 1
R3(config-router)# no auto-summary
R3(config-router)# network 192.168.2.0 0.0.0.3
R3(config-router)# network 192.168.2.12 0.0.0.3
R3(config-router)# network 192.168.2.16 0.0.0.3
R3(config-router)# network 172.16.2.0 0.0.0.255
R3(config-router)# passive-interface fastethernet 0/1

R3# copy running-config startup-config

R4:
Router> en
Router# configure terminal
Router(config)# hostname R4

R4(config)# interface fastethernet 0/0
R4(config-if)# ip address 172.16.4.1 255.255.255.252
R4(config-if)# no shutdown

R4(config)# interface serial 0/3/0
R4(config-if)# ip address 192.168.2.17 255.255.255.252
R4(config-if)# bandwidth 250
R4(config-if)# clock rate 250000
R4(config-if)# no shutdown

R4(config)# interface serial 0/3/1
R4(config-if)# ip address 192.168.2.10 255.255.255.252
R4(config-if)# bandwidth 250
R4(config-if)# no shutdown

R4(config)# router eigrp 1
R4(config-router)# no auto-summary
R4(config-router)# network 192.168.2.8 0.0.0.3
R4(config-router)# network 192.168.2.16 0.0.0.3
R4(config-router)# redistribute rip metric 100000 20 200 50 1500
R4(config-router)# passive-interface fastethernet 0/0

R4(config)# router rip
R4(config-router)# no auto-summary
R4(config-router)# network 172.16.0.0
R4(config-router)# redistribute eigrp 1 metric 2
R4(config-router)# passive-interface serial 0/3/0
R4(config-router)# passive-interface serial 0/3/1

R4# copy running-config startup-config
Табличка маршрутизации 1:
Табличка маршрутизации 2:
Табличка маршрутизации 3:

Табличка маршрутизации 4:

Табличка топологий роутера 1:
На роутерах 1-3 запушен только EIGRP. На роутере 2 настроена редистрибьюция статических маршрутов соседям. На роутере 4 включены два протокола маршрутизации и настроена редистрибьюция маршрутов из EIGRP в RIP и наоборот. На роутере 5 запущен только RIPv2.
Таблица топологии наглядно иллюстрирует работу алгоритма DUAL. Буква P указывает, что маршруты стабильны. Указаны feasible distance, сколько successor-ов на маршрутах и сколько feasible successor-ов.

Комментариев нет:

Отправить комментарий

Примечание. Отправлять комментарии могут только участники этого блога.