понедельник, 20 декабря 2010 г.

Лабораторка на Inter-VLAN Routing

Пример настройки Inter-VLAN Routing на маршрутизаторах/коммутаторах 3 уровня Cisco.
Пример настройки с использованием маршрутизатора:
R1:

R1(config)# interface fastethernet 0/0
R1(config-if)# no ip address
R1(config-if)# no shutdown

R1(config)# interface fastethernet 0/0.2
R1(config-if)# encapsulation dot1q 2
R1(config-if)# ip address 172.16.1.1 255.255.255.0

R1(config)# interface fastethernet 0/0.3
R1(config-if)# encapsulation dot1q 3
R1(config-if)# ip address 172.16.2.1 255.255.255.0

R1# copy running-config startup-config

S0:
S0(config)# vtp domain cisco

S0(config)# vlan 2
S0(config)# vlan 3

S0(config)# interface range fastethernet 0/1-3
S0(config-if)# switchport mode trunk

S0# copy running-config startup-config
Пример настройки с использованием коммутатора 3 уровня:
MS0:
MS0(config)# vtp domain cisco

MS0(config)# vlan 2
MS0(config)# vlan 3

MS0(config)# ip routing

MS0(config)# interface range fastethernet 0/1-2
MS0(config-if)# switchport trunk encapsulation dot1q
MS0(config-if)# switchport mode trunk

MS0(config)# interface vlan 2
MS0(config-if)# ip address 172.16.1.1 255.255.255.0

MS0(config)# interface vlan 3
MS0(config-if)# ip address 172.16.2.1 255.255.255.0

MS0# copy running-config startup-config
Пример настройки коммутаторов 2 уровня (одинаковая для обоих топологий):
S-1-2-3-4:

S(config)# interface range fastethernet 0/1
S(config-if)# switchport mode trunk

S(config)# interface range fastethernet 0/2
S(config-if)# switchport mode access
S(config-if)# switchport access vlan 2

S(config)# interface range fastethernet 0/2
S(config-if)# switchport mode access
S(config-if)# switchport access vlan 3

S# copy running-config startup-config
Проверяем конфигурацию:

PS Если мы создаем на роутере субинтерфейс для native vlan, то это нужно указать в настройке интерфейса
пример: R1(config-if)# encapsulation dot1q 2 native

3 комментария:

  1. Спасибо, последняя строчка очень помогла.

    ОтветитьУдалить
  2. Есть у меня 3750 (типа ядро), и надо чтобы в один ее порт, на котором другая 3750 шли три влана. Я делаю между ними конечно же транк, дот1ку, аллоуед 3 влана 100, 200, 300. Казалось бы, всё должно работать. Но не тут то было! На ядре у меня есть небольшая таблица маршрутизации - просто два статических маршрута. Когда я создаю интерфейс влан200 на ядре, и задаю ему айпи, пересекающийся с сеткой в нативном влане - цыска закономерно ругается. Но без него ведь всё должно работать?

    ОтветитьУдалить
    Ответы
    1. если под работать ты подразумеваешь передачу трафика между цисками по трем вланам с тегом то да, работать будет.
      и конечно циска ругается, ведь ip из одной подсети на разных интерфейсах не разрешено назначать.

      Удалить

Примечание. Отправлять комментарии могут только участники этого блога.