воскресенье, 14 ноября 2010 г.

Лабораторки CCNA #002

Пример настройки протокола динамической маршрутизации RIPv2 на роутерах cisco.
Топология.


Настройка:
R1:
Router> en
Router# configure terminal
Router(config)# hostname R1

R1(config)# key chain cisco
R1(config)# key 1
R1(config)# key-string 234

R1(config)# interface fastethernet 0/0
R1(config-if)# ip address 172.16.1.1 255.255.255.0
R1(config-if)# no shutdown

R1(config-if)# interface fastethernet 0/1
R1(config-if)# ip address 172.16.2.1 255.255.255.0
R1(config-if)# no shutdown

R1(config)# interface serial 1/0
R1(config-if)# ip address 209.165.200.1 255.255.255.252
R1(config-if)# clock rate 64000
R1(config-if)# no shutdown
R1(config-if)# ip rip authentication mode md5
R1(config-if)# ip rip authentication key-chain cisco

R1(config)# router rip
R1(config-router)# no auto-summary
R1(config-router)# network 172.16.0.0
R1(config-router)# network 209.165.200.0
R1(config-router)# passive-interface fastEthernet 0/0
R1(config-router)# passive-interface fastEthernet 0/1
R1(config-router)# version 2

R1# copy running-config startup-config
R2:
Router> en
Router# configure terminal
Router(config)# hostname R2

R2(config)# key chain cisco
R2(config)# key 1
R2(config)# key-string 234

R2(config)# interface fastEthernet 0/0
R2(config-if)# ip address 10.0.0.1 255.255.0.0
R2(config-if)# no shutdown

R2(config)# interface serial 1/0
R2(config-if)# ip address 209.165.200.2 255.255.255.252
R2(config-if)# no shutdown
R2(config-if)# ip rip authentication mode md5
R2(config-if)# ip rip authentication key-chain cisco

R2(config)# interface serial 1/1
R2(config-if)# ip address 209.165.200.5 255.255.255.252
R2(config-if)# clock rate 64000
R2(config-if)# no shutdown
R2(config-if)# ip rip authentication mode md5
R2(config-if)# ip rip authentication key-chain cisco

R2(config)# interface serial 1/2
R2(config-if)# ip address 209.165.200.10 255.255.255.252
R2(config-if)# no shutdown

R2(config)#ip route 0.0.0.0 0.0.0.0 209.165.200.9

R2(config)# router rip
R2(config-router)# no auto-summary
R2(config-router)# redistribute static
R2(config-router)# network 10.0.0.0
R2(config-router)# network 209.165.200.0
R2(config-router)# passive-interface fastEthernet 0/0
R2(config-router)# passive-interface serial 1/2
R2(config-router)# version 2

R2# copy running-config startup-config
R3:
Router> en
Router# configure terminal
Router(config)# hostname R3

R3(config)# key chain cisco
R3(config)# key 1
R3(config)# key-string 234

R3(config)# interface serial 1/1
R3(config-if)# ip address 209.165.200.6 255.255.255.252
R3(config-if)# no shutdown
R1(config-if)# ip rip authentication mode md5
R1(config-if)# ip rip authentication key-chain cisco

R3(config)# interface fastEthernet 0/0
R3(config-if)# ip address 172.16.200.1 255.255.255.128
R3(config-if)# no shutdown

R3(config)# interface fastEthernet 0/1
R3(config-if)# ip address 172.16.100.1 255.255.255.128
R3(config-if)# no shutdown

R3(config)# router rip
R3(config-router)# no auto-summary
R3(config-router)# network 209.165.200.0
R3(config-router)# network 172.16.0.0
R3(config-router)# passive-interface fastEthernet 0/0
R3(config-router)# passive-interface fastEthernet 0/1
R3(config-router)# version 2

R3# copy running-config startup-config
Проверяем:
Таблица маршрутизации 1:
Таблица маршрутизации 2:
Таблица маршрутизации 3:

PS между маршрутизаторами настроен RIPv2 и авторизация с md5 шифрованием. Отключены, автосуммаризация и анонсирование обновений маршрутов на FastEthernet интерфейсах.

2 комментария:

  1. R1(config-if)# ip rip authentication mode md5
    R1(config-if)# ip rip authentication key-chain cisco

    R1(config)# router rip
    R1(config-router)# no auto-summary
    R1(config-router)# network 172.16.0.0
    R1(config-router)# network 209.165.200.0
    R1(config-router)# passive-interface fastEthernet 0/0
    R1(config-router)# passive-interface fastEthernet 0/1
    R1(config-router)# version 2

    Вот это кусок листинга только у тебя в лабораторной работе по RIP в рамках курса CCNA. Больше нигде такого не видел. Это потому что я находил устаревшие лабораторные работы, и уже нужно авторизацию настраивать и отключать анонсирование и авто суммирование или потому что ты решил что без этого лабораторная работа по этой теме будет не полной?

    ОтветитьУдалить
  2. суммаризация и пассив интерфейсы на лабах делается, кроме авторизации... настройка авторизации в рипе в ccna не рассматривается. там только упоминается что она есть...

    ОтветитьУдалить

Примечание. Отправлять комментарии могут только участники этого блога.