вторник, 9 августа 2011 г.

IPv6 Manual P-t-P Tunnel

Пример настройки туннеля соединяющего две IPv6 сети поверх сети IPv4.
Топология:

Настройка:
R1:
!
ipv6 unicast-routing
!
interface Tunnel0
ipv6 address 2001:1:2:3::1/126
ipv6 rip cisco enable
tunnel source FastEthernet0/0
tunnel destination 209.165.200.2
tunnel mode ipv6ip
!
interface FastEthernet0/0
ip address 209.165.200.1 255.255.255.252
!
interface FastEthernet0/1
ipv6 address 2001:1:2:3::101/120
ipv6 enable
ipv6 rip cisco enable
!
ipv6 router rip cisco
!
R2:
!
ipv6 unicast-routing
!
interface Tunnel0
ipv6 address 2001:1:2:3::2/126
ipv6 rip cisco enable
tunnel source FastEthernet0/0
tunnel destination 209.165.200.1
tunnel mode ipv6ip
!
interface FastEthernet0/0
ip address 209.165.200.2 255.255.255.252
!
interface FastEthernet0/1
ipv6 address 2001:1:2:3::201/120
ipv6 enable
ipv6 rip cisco enable
!
ipv6 router rip cisco
!
Проверяем:
Таблица маршрутизации R1:
Вывод sh int tun 0:
Вывод sh ipv6 int tun 0:
Таблица маршрутизации R2:
  • MTU протокола пассажира в данном случае 1480
  • для маршрутизации пакетов используется RIPng, так же можно было использовать и статические маршруты
  • link-local адрес туннельного интерфейса генерируется из FE80::/96 и ipv4 адреса источника тоннеля (209.165.200.1 = D1A5:C801)
  • в качестве протокола пассажира может выступать только ipv6

Комментариев нет:

Отправить комментарий

Примечание. Отправлять комментарии могут только участники этого блога.